Communication issue between laptop and QD pattern generator and 780 drivers added

Communication issue between laptop and QD pattern generator and 780 drivers added

Home Forums General Chit Chat and Other Stuff Communication issue between laptop and QD pattern generator and 780 drivers added

  • Creator
  • #479

    I use the Chromapure but I encounter a problem in driving the QuantumData 780.

    I have read both the Chromapure and QD780 manuals, I have installed the QD780.inf file as recommended and followed the instructions step by step.

    Computer is a HP NC6400 with XP. (Tried also with a Dell Inspiron 510m)
    The generator is on com3. I configure the port, then click on the Test
    button. Test is successful.

    Signal generator and auto advance are enabled.
    Then I call the grayscale test, set my generator on Window test pattern,
    starting at 10% and click on the Measure button.
    The software proceeds to the test in 10% increments but the generateur
    doesn’t follow and remains at 10%.

    If I proceed to test the generator again, a warning message says :
    opening port failure !
    Unhandled exception has occured in your application… Access to com3 is
    This is a known problem that will be fixed with the next release.

    Gregg recommends using a hub. From his experience, this solves the problem.
    I haven’t tried yet (need to buy the hub first). I’ll keep you informed.

    Anyone experienced this issue ?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
  • #1987
    Gregg Loewen

    HI JP

    the laptops you are using (HP and Dell) are the same as our classroom. We need to use a hub on each of them in the classroom otherwise they will try to change comm ports and lock the program up.

    This is not a chromapure problem. This same problem exists with CalMan too. In fact it was a Calman tech support person that told me to try the USB hub.


    Here is a link to the qd780 driver:


    Ok Gregg.
    I have installed the system with a hub. It doesn’t make any difference.
    The Chromapure test is successful but the computer does not drive the generator.


    I have installed the software on 4 machines and it is still the same with all of them. With or without the hub.

    Am I doing something wrong with the Quantum ?
    Is there any special setting I haven’t seen ?


    I have re-installed the QD780.inf driver on another machine (Dell Inspiron)

    All installation messages, tests, initialization… are ok.
    But the QD remains frozen.

    If anyone has had some experience with it, help would be welcome.

    Gregg Loewen

    turn everything off and reboot the PC.
    Then turn the QD On.
    Go into Device manager / hardware and look for the QD. It will be labelled as a USB Device and assigned a port.
    Once you get the port #, then start the CP software. IT IS IMPORTANT that after you start the CP software that you DO NOT TOUCH the QD anymore.
    Now select the signal generator AND THE COMM port, and then hit the test button.
    Select the window option, RGB, and the resolution.
    You will be good to go.


    Hmmm… I don’t see the QD in the USB devices list.

    Gregg Loewen

    hi JP
    Keep the faith
    you are looking in the wrong spot.
    Look under Ports (comm and LPT).
    If you loaded the drivers correctly there should be one that says: USB COM Port (COMXX) ….with the XX being what ever port your QD is assigned.

    Then start the CP program and then select the 780 and chose this comm port.


    Gregg Loewen


    Here is where to look for the com assignment. Mine is com 19

    Gregg Loewen


    the example on the right is with selecting the correct com port, then hitting test, this is what you should see.

    the example on the left is the screen after the one on the right, where you select the settings for the QD.


    Things are getting better.

    I have finally found the QD port hidden at the bottom of the list.
    When I check the driver details I read: usbser.sys and not QD780.inf
    Is this correct ?

    Ok, let’s go ahead.
    Then, I followed your instructions.
    With the generator options I’ve selected the correct port (#8 instead of #3 proposed as default). That’s something I didn’t do before because I didn’t know the port assignment! (first mistake).
    By the way, I noticed that I can perform a successful test on a wrong port. That is misleading!
    I noticed also that we cannot do a second test. The system closes down.

    Finally, I got it working ! 😀

    While the sequence scrolls the IRE levels on the TV screen the IRE label (if displayed) doesn’t change. Is this correct too?
    Previously, I didn’t use the TV for testing. I was expecting changes on the QD display (second mistake).

    During the training, I used mostly Calman. I didn’t have much opportunities to play with Chromapure and I didn’t remember those details.

    Can you please give me your comments on the above questions.
    Thanks Gregg for your help.

    Gregg Loewen

    (if displayed) doesn’t change

    This display of the IRE is a bug on the QD generator (nothing to do with CalMan or ChromaPure).

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.